Eclipse: Could not initialize class org.eclipse.wst.server.ui.internal.provisional.UIDecoratorManager

The following error message in Eclipse:


An error has occurred. See error log for more details.
Could not initialize class org.eclipse.wst.server.ui.internal.provisional.UIDecoratorManager

is a known bug.

The bug is now fixed in WTP 3.1.2. To fix it, update to WTP 3.1.2 (go to Help->Check for Updates).

There is no official solution, but people are reporting luck if they start Eclipse in the Java EE perspective and with the Servers tab visible.